Advanced BBCode Box 3

BBCodes & smilies NOT WORKING when clicked on - Advanced BBCode Box 3

BBCodes & smilies NOT WORKING when clicked on

New postby JohnGr » Sun Apr 21, 2013 9:33 am

Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? http://forum.4bitgg.com
Who do you host your board with? Hostgator
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
What MODs do you have installed? WP-UNITED: WordPress-phpBB Integration Package

I also had Advanced BBCode Box 3 which I uninstalled but that might be causing the problem
What styles do you currently have installed? prosilver, subsilver2
What language(s) is your board currently using? English
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? SupportAccount
What password can be used to view this issue? 123456789
When did your problem begin? Somewhere around the time I installed Advanced BBCode Box 3
Please describe your problem. On posting / editing page, BBCodes and smilies don't work when they are clicked on. BBCodes work fine when you type them manually.

I've noticed that they don't work when I installed Advanced BBCode Box 3. After that I uninstalled it but it still didn't work and all the custom bbcodes are still displayed on the posting / editing page. Even after I completely deleted it from my server, they are still there.

I also can't get rid of additional menus located in ACP -> Posting:
"ADVANCED BBCODE BOX 3"
ABBC3 Settings
ABBC3 BBCodes

Only other mod I'm using is "WP-UNITED: WordPress-phpBB Integration Package"

Any help regarding this would be highly appreciated since I have absolutely no idea how to fix this short of re-installing the whole forum. :(
JohnGr
Registered User
 
Posts: 4
Joined: Wed Apr 17, 2013 3:55 pm

Re: BBCodes & smilies NOT WORKING when clicked on

New postby KOKOStern » Fri Apr 26, 2013 11:57 am

I have the exact same problem, with WP-UNITED installed. This probably means that the plugin is causing the problem, the question is why, how, and how to solve it.

Did you find any solution?
KOKOStern
Registered User
 
Posts: 6
Joined: Fri Apr 26, 2013 11:55 am

Re: BBCodes & smilies NOT WORKING when clicked on

New postby KOKOStern » Fri Apr 26, 2013 7:16 pm

Found it!

I knew it was something stupid and annoying:

editor.js is edited in the WP-UNITED installation:
Code: Select all
document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px;">');

document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px; background-color: #' + color + [b];[/b]">');


They forgot a god damn tiny little ' before that ;

The reason it didn't when I got the fresh prosilver install is due to me not being familiar with phpbb enough to know I need to refresh themes as well as purge the cache.
KOKOStern
Registered User
 
Posts: 6
Joined: Fri Apr 26, 2013 11:55 am

Re: BBCodes & smilies NOT WORKING when clicked on

New postby mykkal » Mon Apr 29, 2013 1:46 am

I'm having this problem too and can't get it fixed. What is the filepath to the js editor? And using phpBB terminology, what exactly do we remove and what exactly do we replace with?
mykkal
Registered User
 
Posts: 38
Joined: Wed Aug 31, 2005 12:06 am

Re: BBCodes & smilies NOT WORKING when clicked on

New postby FlexyClown » Thu May 02, 2013 5:58 pm

in you phpbb install go to:

styles\prosilver\template\editor.js

Replace:

Code: Select all
document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px; background-color: #' + color + ;">');


with:

Code: Select all
document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px; background-color: #' + color + ';">');
FlexyClown
Registered User
 
Posts: 85
Joined: Thu May 13, 2004 7:20 pm

Re: BBCodes & smilies NOT WORKING when clicked on

New postby JohnGr » Thu May 16, 2013 1:46 pm

Oh that solved the problem, I hate it when these kind of things happen. Thank you so much, I was about to pull my hair out. :D
JohnGr
Registered User
 
Posts: 4
Joined: Wed Apr 17, 2013 3:55 pm

Re: BBCodes & smilies NOT WORKING when clicked on

New postby nallatheryth » Thu Jul 04, 2013 6:25 pm

Hide
JohnGr wrote:Oh that solved the problem, I hate it when these kind of things happen. Thank you so much, I was about to pull my hair out. :D


Same here - Thank you soooo much! I was going crazy and all because of a simple ' ?

heheheh - all peachy now - onto other issues I am having ;)
nallatheryth
Registered User
 
Posts: 4
Joined: Thu Jul 04, 2013 6:23 pm

Re: BBCodes & smilies NOT WORKING when clicked on

New postby akerd » Mon Sep 09, 2013 11:11 pm

Hide
KOKOStern wrote:Found it!

I knew it was something stupid and annoying:

editor.js is edited in the WP-UNITED installation:
Code: Select all
document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px;">');

document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px; background-color: #' + color + [b];[/b]">');


They forgot a god damn tiny little ' before that ;

The reason it didn't when I got the fresh prosilver install is due to me not being familiar with phpbb enough to know I need to refresh themes as well as purge the cache.


Thank you very much, you saved my an headache
akerd
Registered User
 
Posts: 2
Joined: Fri Sep 06, 2013 3:42 pm

Re: BBCodes & smilies NOT WORKING when clicked on

New postby Zanzibar » Tue Sep 24, 2013 6:09 pm

Hmm. I appear to have run into the same trouble as the other people in this thread, but the solution offered doesn't seem to work for me.

I've tried a fresh Wordpress and PHPbb install twice, and changing the editor.js file both times, but still the same error.

As a reference:
Code: Select all
{
            color = String(numberList[r]) + String(numberList[g]) + String(numberList[b]);
            document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px; background-color: #' + color + ;">');
            document.write('<a href="#" onclick="bbfontstyle(\'[color=#' + color + ']\', \'[/color]\'); return false;"><img src="images/spacer.gif" width="' + width + '" height="' + height + '" alt="#' + color + '" title="#' + color + '" /></a>');
            document.writeln('</td>');
         }

         if (dir == 'v')
         {
            document.writeln('</tr>');
         }


This is, I believe, the relevant portion of editor.js . Have I missed something?

All the integration features have worked wonderfully. It'd just be a shame if it fell on this bit!

Also worth noting that I have no other plugins installed.

Perhaps someone can send me their editor.js file for me to try out?

Thanks for any help I receive!
Zanzibar
Registered User
 
Posts: 1
Joined: Tue Sep 24, 2013 6:00 pm

Re: BBCodes & smilies NOT WORKING when clicked on

New postby VSE » Wed Sep 25, 2013 7:44 pm

as mentioned above, this color + ;">' needs to be color + ';">'
Last edited by VSE on Sun Mar 09, 2014 2:37 am
My MODs:
Topic Preview | Precise Similar Topics II | Show Password Strength
PM Box Progress Bars | DB Optimize & Repair Tool | IE6 No More
Please do not PM me for support.
User avatar
VSE
Extensions Development Team
 
Posts: 1662
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman

Re: BBCodes & smilies NOT WORKING when clicked on

New postby Sebio » Sat Mar 08, 2014 9:28 am

Hello,
my web site : http://www.cwol.fr/forum/
i have a same problem with my template artodia elegance
but i don't have in editor.js this code : present into prosilver and function
Code: Select all
for (b = 0; b < 5; b++)
         {
            color = String(numberList[r]) + String(numberList[g]) + String(numberList[b]);
            document.write('<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px; background-color: #' + color + ';">');
            document.write('<a href="#" onclick="bbfontstyle(\'[color=#' + color + ']\', \'[/color]\'); return false;"><img src="images/spacer.gif" width="' + width + '" height="' + height + '" alt="#' + color + '" title="#' + color + '" /></a>');
            document.writeln('</td>');
         }


I have this code :
Code: Select all
for (b = 0; b < 5; b++)
         {
            color = String(numberList[r]) + String(numberList[g]) + String(numberList[b]);
            html += '<td bgcolor="#' + color + '" style="width: ' + width + 'px; height: ' + height + 'px; background-color: #' + color + ;">';
            html += '<a href="#" onclick="bbfontstyle(\'[color=#' + color + ']\', \'[/color]\'); return false;"><img src="images/spacer.gif" width="' + width + '" height="' + height + '" alt="#' + color + '" title="#' + color + '" /></a>';
            html += '</td>';
         }


Thanks for help.
Sebio
Registered User
 
Posts: 3
Joined: Thu Sep 19, 2013 8:08 am

Re: BBCodes & smilies NOT WORKING when clicked on

New postby VSE » Sun Mar 09, 2014 2:36 am

See post right above yours...
My MODs:
Topic Preview | Precise Similar Topics II | Show Password Strength
PM Box Progress Bars | DB Optimize & Repair Tool | IE6 No More
Please do not PM me for support.
User avatar
VSE
Extensions Development Team
 
Posts: 1662
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman

Re: BBCodes & smilies NOT WORKING when clicked on

New postby Sebio » Sun Mar 09, 2014 9:02 am

I have replace code into html += '....';
with into document.write('....')

it's good now.
Sebio
Registered User
 
Posts: 3
Joined: Thu Sep 19, 2013 8:08 am