Warning: The author of this contribution does not provide support for it anymore.

Board3 Portal

Style Switcher - Board3 Portal

Style Switcher

by SteveW1805 » Fri Sep 03, 2010 5:43 am

I installed this mod and it looks very good. Thank you.

However, when I activated the style switcher, installed subsilver2, and then selected subsilver2 from the portal I got the following error:

template->_tpl_load_file(): File ./styles/subsilver2/template//portal/portal_body.html does not exist or is empty

I installed the mod using automod.

Is this supported or have I gone wrong somewhere?

Many thanks for any help.

S
SteveW1805
Registered User
Posts: 61
Joined: Fri Jun 19, 2009 1:46 am
Contact:

Re: Style Switcher

by Marc » Fri Sep 03, 2010 7:18 am

You need to run the subsilver2 instructions using AutoMOD.
User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5484
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Style Switcher

by noth » Tue Jul 03, 2012 10:41 am

this means that the style switcher only works if all the styles on your forums are modded with portal

I find this disappointing

why can't an admin apply the portal to half his styles only? I think the portal particularly suits floating width styles but not quite so good for fixed width

but if I decide to leave the fixed width ones, then I have to take out the style switcher :?

is it possible to make the style switcher just point to the index.php of every style and not the portal please? 8-)
User avatar
noth
Registered User
Posts: 2487
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Style Switcher

by YOUAREtehSCENE » Sat Jan 23, 2016 4:52 am

General Error
template->_tpl_load_file(): File ./styles/subsilver2/template/portal/portal_body.html does not exist or is empty

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_template.php
LINE: 63
CALL: trigger_error()

FILE: [ROOT]/includes/template.php
LINE: 437
CALL: template_compile->_tpl_load_file()

FILE: [ROOT]/includes/template.php
LINE: 224
CALL: template->_tpl_load()

FILE: [ROOT]/includes/functions.php
LINE: 4900
CALL: template->display()

FILE: [ROOT]/portal.php
LINE: 185
CALL: page_footer()

How does one fix this?
YOUAREtehSCENE
Registered User
Posts: 178
Joined: Wed Feb 11, 2009 3:35 am
Location: Boston, Mass
Contact: