Warning: The author of this contribution does not provide support for it anymore.

Bots Install Script

Instalation Problem - Bots Install Script

Instalation Problem

by rexx » Mon May 02, 2011 3:35 pm

When logged in as admin, I tried going to: /phpbb3/bots.php, but, instead, I got:

SQL ERROR [ mysql4 ]

Duplicate entry 'java [bad bot]' for key 2 [1062]

SQL

INSERT INTO phpbb3_users (username, username_clean, user_password, user_pass_convert, user_email, user_email_hash, group_id, user_type, user_permissions, user_timezone, user_dateformat, user_lang, user_style, user_actkey, user_ip, user_regdate, user_passchg, user_options, user_new, user_inactive_reason, user_inactive_time, user_lastmark, user_lastvisit, user_lastpost_time, user_lastpage, user_posts, user_dst, user_colour, user_occ, user_interests, user_avatar, user_avatar_type, user_avatar_width, user_avatar_height, user_new_privmsg, user_unread_privmsg, user_last_privmsg, user_message_rules, user_full_folder, user_emailtime, user_notify, user_notify_pm, user_notify_type, user_allow_pm, user_allow_viewonline, user_allow_viewemail, user_allow_massemail, user_sig, user_sig_bbcode_uid, user_sig_bbcode_bitfield, user_form_salt, user_note) VALUES ('Java [Bad bot]', 'java [bad bot]', '', 0, '', '00', 6, 2, '', 0, 'D M d, Y g:i a', 'en', 1, '', '', 1304350208, 1304350208, 230271, 0, 0, 0, 1304350208, 0, 0, '', 0, 1, '9E8DA7', '', '', '', 0, 0, 0, 0, 0, 0, 0, -3, 0, 0, 1, 0, 1, 1, 1, 0, '', '', '', '69f7ddc4757bfa4e', '')

BACKTRACE


FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/functions_user.php
LINE: 251
CALL: dbal_mysql->sql_query()

FILE: bots.php
LINE: 191
CALL: user_add()

FILE: bots.php
LINE: 207
CALL: add_bots2()



Any thoughts on how to resolve this?

- r
rexx
Registered User
Posts: 664
Joined: Fri Feb 25, 2005 9:20 pm
Contact:

Re: Instalation Problem

by Pony99CA » Tue May 03, 2011 8:31 am

This problem was described and explained in the old discussion topic. Basically, the script isn't smart enough to handle bots that you already have defined.

You might want to look at my manage_bots script instead (see my signature). I initially wrote it to specifically handle this problem, plus my script has 300+ bots (including every bot but one in this MOD -- and I've just added that for the next release) and lots of other features (adding the default bots back, deleting/activating/deactivating bots, listing bots in your database that aren't in the script, etc.).

To be fair, this MOD has two advantages over my script -- it's a true, validated MOD and it uses the language files for easier translation (my script is English only).

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.
Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: Instalation Problem

by rexx » Tue May 03, 2011 3:05 pm

The script looks promising!

Forgive my ignorance, however, but should I save the script as a file, called: manage_bots.php, and then ftp it up to /phpbb3/?

- r

************************************

UPDATE:
(May 3, 2011)



Using the script, I just created and uploaded manage_bots.php up to /phpbb3/. But, after invoking the file, the following occurred:


Updated 123spider
Updated 24spider
Updated ASPseek
Updated Bunnybot
Updated Cometrics
Updated Cosmix
Updated Crawler Search
Updated Diggit!
Updated Esperanza
Warning: Exabot [Bot]'s agent conflicts with Exabot!

Updated Exabot [Bot]
Updated Findexa Crawler
Updated ichiro [Crawler]
Updated MMSBot
Updated MP3-Bot
Updated PlantyNet

Warning: Cannot modify header information - headers already sent by (output started at /home/ccccc/public_html/phpbb3/manage_bots.php:1490) in /home/ccccc/public_html/phpbb3/includes/functions.php on line 2641

Return to the index page
General Error
SQL ERROR [ mysql4 ]

Table 'ccccc_ccccc3.phpbb3_privmsgs_rules' doesn't exist [1146]

SQL

DELETE FROM phpbb3_privmsgs_rules WHERE user_id = 88392

BACKTRACE


FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/functions_user.php
LINE: 564
CALL: dbal_mysql->sql_query()

FILE: manage_bots.php
LINE: 1077
CALL: user_delete()

FILE: manage_bots.php
LINE: 1493
CALL: remove_bot()

FILE: manage_bots.php
LINE: 911
CALL: update_bots()


What do you suggest?

- r
rexx
Registered User
Posts: 664
Joined: Fri Feb 25, 2005 9:20 pm
Contact:

Re: Instalation Problem

by Pony99CA » Tue May 03, 2011 10:50 pm

First, I suggest posting in the topic where you got the manage_bots script. This area is for the specific Bots Install MOD, not my script, so I don't want to hijack this topic.

When you post there, please fill out the Support Request Temp.ate and paste that into your post to give me more details about your problem.

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.
Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: Instalation Problem

by rexx » Tue May 03, 2011 11:58 pm

Sorry about placing my post in the wrong place. Hopefully, I corrected that.

- r
rexx
Registered User
Posts: 664
Joined: Fri Feb 25, 2005 9:20 pm
Contact: