Warning: The author of this contribution does not provide support for it anymore.

Breizh Ajax Checks

Tab Does not Work in Some Fields - Breizh Ajax Checks

Tab Does not Work in Some Fields

by victory1 » Sun Apr 08, 2012 5:26 pm

If you use tab to get to the next field from the 1st e-mail and the 1st password fields, it stays on the processing loop if the email address is not in use ( it actually immediately tell you if the e-mail address is taken or too short). It only stop processing immediately if you directly click into the next box (confirm for e-mail and password) and not tab to the confirm boxes. The endless processing does not affect registration. I'm just curious if I'm the only one experiencing this.

Note: I love this version because the Username Field finally works for me. The previous version, it would never check the username field. I checked my edits over and over again, even had a friend check it for me to make sure I was not missing anything. Anyway, I actually uninstall the last version instead of updating and re-install the new one. Everything went smoothly and all the fields are now working. :)
Attachments
regcheck2.PNG
That's clicking directly into the box of the next field
regcheck1.PNG
That's tabbing to the next field
User avatar
victory1
Registered User
Posts: 935
Joined: Sun Oct 10, 2010 6:47 pm
Contact:

Re: Tab Does not Work in Some Fields

by sylver35 » Tue Apr 10, 2012 4:51 pm

hello,

If you use tab to get to the next field

this mod is designed to work with the mouse and keyboard, use the Tab key blocks ajax, I can not do anything for that...
Hello world !
User avatar
sylver35
Registered User
Posts: 151
Joined: Sat Feb 23, 2008 2:38 pm
Location: France / Bretagne
Name: Philippe
Contact:

Re: Tab Does not Work in Some Fields

by victory1 » Wed Apr 11, 2012 2:30 am

Thanks sylver35 for answering! :) That's OK, I was just curious.
User avatar
victory1
Registered User
Posts: 935
Joined: Sun Oct 10, 2010 6:47 pm
Contact:

Re: Tab Does not Work in Some Fields

by sylver35 » Fri Apr 27, 2012 2:05 pm

Hello world !
User avatar
sylver35
Registered User
Posts: 151
Joined: Sat Feb 23, 2008 2:38 pm
Location: France / Bretagne
Name: Philippe
Contact:

Re: Tab Does not Work in Some Fields

by sylver35 » Tue May 22, 2012 2:57 pm

The new version 1.3.0 has arrived and 100% operational
=> http://breizh-portal.com/mod-breizh-aja ... t1486.html
Hello world !
User avatar
sylver35
Registered User
Posts: 151
Joined: Sat Feb 23, 2008 2:38 pm
Location: France / Bretagne
Name: Philippe
Contact:

Re: Tab Does not Work in Some Fields

by victory1 » Wed May 23, 2012 3:15 pm

sylver35 wrote:The new version 1.3.0 has arrived and 100% operational
=> http://breizh-portal.com/mod-breizh-aja ... t1486.html


I updated and now have the same problem I had with the username field that I had with version 1.1. It is ignoring it. The last version fixed problem. Since the username is the 1st field and user has to click into that box anyway, could I undo the new edits for just that field?
Attachments
register.PNG
User avatar
victory1
Registered User
Posts: 935
Joined: Sun Oct 10, 2010 6:47 pm
Contact:

Re: Tab Does not Work in Some Fields

by sylver35 » Thu May 24, 2012 6:54 am

Hello,

I have see the problem.
You have a custom login form in javascript in your overall_header.html
It contains an input with name="username" id="username" who create a bug with the field registration form.
Never have two identical id in same page !!

in file overall_header.html, search:

Code: Select all

<!-- IF not S_USER_LOGGED_IN  --><div id="login_child" style="margin-top: 37px; margin-left: -125px; z-index: 1;"><form action="{U_LOGIN_LOGOUT}" method="post"> 

replace with:

Code: Select all

<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED and not (S_SHOW_COPPA or S_REGISTRATION) -->
<div id="login_child" style="margin-top: 37px; margin-left: -125px; z-index: 1;">
<form action="{U_LOGIN_LOGOUT}" method="post">
Hello world !
User avatar
sylver35
Registered User
Posts: 151
Joined: Sat Feb 23, 2008 2:38 pm
Location: France / Bretagne
Name: Philippe
Contact:

Re: Tab Does not Work in Some Fields

by victory1 » Thu May 24, 2012 12:58 pm

Thank you sylver35! Everything is now working flawlessly. :D
User avatar
victory1
Registered User
Posts: 935
Joined: Sun Oct 10, 2010 6:47 pm
Contact: