Warning: The author of this contribution does not provide support for it anymore.

Multiple Newsletters Add On

Multiple Newsletters Add On Compatible with PHPBB 3.0.12? - Multiple Newsletters Add On

Multiple Newsletters Add On Compatible with PHPBB 3.0.12?

by frankbackes » Wed Jan 08, 2014 1:38 am

Hi,

In the description I could find in the FAQ that the MOD is compatible with 3.0.11 but not if it's also for 3.0.12.
https://www.phpbb.com/customise/db/mod/ ... rs_add_on/
Does anybody know if it is or not?

Thank you

Frank
frankbackes
Registered User
Posts: 8
Joined: Tue Apr 24, 2012 1:18 pm
Contact:

Re: Multiple Newsletters Add On Compatible with PHPBB 3.0.12

by Martin Truckenbrodt » Mon Jan 13, 2014 4:33 pm

Hello frankbackes,
I haven't tested it by now.
At the moment I don't have any time for programming MODs for phpBB.

Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Re: Multiple Newsletters Add On Compatible with PHPBB 3.0.12

by mrechte » Thu Oct 09, 2014 7:48 pm

Hello,

I have installed the mod on phpBB 3.0.12. I got some problems with languages/fr.xml that were easily fixed.

The MOD indicates it has been successfully installed (AUTOMOD) but the database tables have not been created.

Is that a 3.0.12 related problem ?

Thanks
mrechte
Registered User
Posts: 4
Joined: Thu Oct 09, 2014 7:37 pm
Contact:

Re: Multiple Newsletters Add On Compatible with PHPBB 3.0.12

by Martin Truckenbrodt » Fri Oct 10, 2014 8:39 am

Hello mrechte,
on the end of the installation process with AutoMOD there is a blueish highlighted advice to run umil_auto_newsletter.php in your browser. E.g. open/run http://<yourdomain>/umil_auto_newsletter.php now.
Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Re: Multiple Newsletters Add On Compatible with PHPBB 3.0.12

by mrechte » Fri Oct 10, 2014 10:10 am

Thanks for your prompt answer.

First what you state is not shown after installing the mod (see attached capture). The link to finish the installation brings an error (see attached capture).

I ran the suggested script but it brings a version error for UMIL (see attached capture).

Is this error related to the your add on or to my phpBB installation (3.0.12) ?

Thanks
Attachments
InstallMOD_newsletter.png
InstallMOD_newsletter2.png
InstallMOD_newsletterUMIL.png
mrechte
Registered User
Posts: 4
Joined: Thu Oct 09, 2014 7:37 pm
Contact:

Re: Multiple Newsletters Add On Compatible with PHPBB 3.0.12

by Martin Truckenbrodt » Sat Oct 11, 2014 12:10 pm

Hello,
I'm quite sure taht it is a problem with your board.
Set English for your personal language at your board and try it again.
Also you should update your UMIL installation. But it's possible that the UMIL files included at the MOD dowmload package are outdated. It's a silly rule for MODs that UMIL has to be directly included MOD packackes if MODs are using UMIL.
Please have a look here: https://www.phpbb.com/customise/db/mod/ ... _-t_103384

The MOD is compatible with UMIL and AutoMOD. But I prefer manually installation of MODs. On the end it's easier, the safe way and doesn't need more time for instalaltion.

Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Re: Multiple Newsletters Add On Compatible with PHPBB 3.0.12

by mrechte » Tue Oct 14, 2014 4:08 pm

Hello Martin,

Thanks again for your help.

Changing the default language has no effect on the problem.

I checked the umil version provided with phpBB3: 1.0.4, the same than the one supplied with your package.

So I just ignored the warning when running umil script. It succeeded without error :)

I think this warning is an online check for a newer umil version available for download.

To help other users I attached the modified translation file.

Best regards

Marc
Attachments
fr.xml.gz
(3.82 KiB) Downloaded 257 times
mrechte
Registered User
Posts: 4
Joined: Thu Oct 09, 2014 7:37 pm
Contact: