Warning: The author of this contribution does not provide support for it anymore.

phpBB Gallery

Updating from 1.0.4 - phpBB Gallery

Updating from 1.0.4

by Hippie459MN » Tue Feb 05, 2013 11:39 pm

I was wondering, I have one of my forums and I am working on doing a bunch of major updates to it and currently its on an old version of the gallery (1.0.4) and I was wondering what would be the easiest way to update to the latest version? I notice in the contrib folder it starts at version 1.0.6 and goes up to each version. Can I just uninstall version 1.0.4 and then install the latest without loosing any of the users galleries? I am just looking for the simplest and best way to do this without loosing anything.

Thank you.
User avatar
Hippie459MN
Registered User
Posts: 915
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Updating from 1.0.4

by Hippie459MN » Wed Feb 20, 2013 11:54 pm

I had a very old version of the gallery installed (v1.0.4) and trying to update to 1.1.6 and I have removed all of the 1.0.4 edits in all of the files and deleted all of the gallery files except for the uploads and thumbnails folders in root/gallery so I do not loos the 500+ images I have and then installed 1.1.6 using the new edits and files and when I went to the update tab I got the included error.

I was wondering how I can update the DB without loosing any of my uploads and such. I hate to revery my files back and have to stay with 1.0.4.

Code: Select all

General Error
Sorry, but your updates prior to 1.0.6 are not supported from this install/update-system.

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/install/install_update.php
LINE: 407
CALL: trigger_error()

FILE: [ROOT]/install/install_update.php
LINE: 88
CALL: install_update->update_db_schema()

FILE: [ROOT]/install/index.php
LINE: 189
CALL: install_update->main()

FILE: [ROOT]/install/index.php
LINE: 61
CALL: module->load()
User avatar
Hippie459MN
Registered User
Posts: 915
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Updating from 1.0.4

by Hippie459MN » Thu Feb 21, 2013 4:03 am

Awesome. Now that I cant update the database for the gallery I can not even get into my UCP and neither can any of my users. Getting a message saying database not up to date.

I really hate to revery back to my back up if I dont have to. Anyone? Nick?
User avatar
Hippie459MN
Registered User
Posts: 915
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Updating from 1.0.4

by deejay_xb » Wed Mar 27, 2013 11:15 am

I have 1.0.6 and i'm afraid to update.. to many pictures/album and also gallery block integrated with board3 portal ... so if anyone has a smooth way to update please post!
deejay_xb
Registered User
Posts: 62
Joined: Mon Nov 21, 2011 5:43 pm
Contact:

Re: Updating from 1.0.4

by djrx » Sun Jul 07, 2013 12:17 pm

bump same problem 1.0.4 looking for best update method
djrx
Registered User
Posts: 7
Joined: Mon May 20, 2013 4:47 am
Contact:

Re: Updating from 1.0.4

by deejay_xb » Wed Oct 09, 2013 8:17 pm

any support here??!
deejay_xb
Registered User
Posts: 62
Joined: Mon Nov 21, 2011 5:43 pm
Contact:

Re: Updating from 1.0.4

by Hippie459MN » Wed Oct 09, 2013 8:22 pm

It doesnt look like it at all. Bummer too.
User avatar
Hippie459MN
Registered User
Posts: 915
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Updating from 1.0.4

by 5hocK » Wed Oct 09, 2013 8:26 pm

I'd setup a test site - an exact copy of the board and database and update that, see how it goes.
I don't think there's any official support anymore either - or if there is it's going to be very limited, see this post: http://www.flying-bits.org/viewtopic.php?f=2&t=4268
A thread is pretty much a topic. Stop with the pedantics will ya.
User avatar
5hocK
Registered User
Posts: 3011
Joined: Wed Nov 23, 2011 7:00 pm
Location: England