Warning: The author of this contribution does not provide support for it anymore.

phpBB jQuery Base

No more login on disabled board - phpBB jQuery Base

No more login on disabled board

by draky » Wed Oct 02, 2013 7:26 pm

Hello

Just tested a fresh phpBB 3.0.12 install and got a very annoying problem !

First, with AutoMOD, there was no problem at all.

So, here is how to reproduce the problem :

- fresh install of phpBB 3.0.12 + autoMOD 1.0.2
- install of jQ Base with automod
- disabling board in config
- going to board index
- logout

Problem : there is no more login form at the bottom and the "login" link on the upper right is not responding !

Something still strange above that : in phpMyAdmin, I set the "disable_board" to "0" in phpbb_config table but it doesn't change anything !
Was stuck out of the forum because I couldn't login anymore and I was not able to disable the "disabled board config" !

Any idea ?

Only solution : I deleted both mysql tables and phpBB files (for a test forum)...

EDIT : tried with a fresh 3.0.11 and same problem occurred : no login possible if board is disabled !
You can see the login link failed here : http://www.ouahouah.eu/phpBB3/ (3.0.11)

EDIT2 : found a solution : you need to go to login link directly : https://www.xxx.com/phpBB/ucp.php?mode=login and then you can login and then re-enable the board and the login with jquery works...

So... not a 3.0.12 problem but a jQuery problem with login link when board is disabled ?

EDIT3 : change of title from "Not compatible with login on 3.0.12 ?"
User avatar
draky
Registered User
Posts: 247
Joined: Tue Dec 10, 2002 2:04 pm
Location: France
Name: Gilles W.
Contact:

Re: No more login on disabled board

by draky » Mon Oct 07, 2013 11:12 am

Fix commited by the author so if anyone wants it, just download the MOD from Github :)
User avatar
draky
Registered User
Posts: 247
Joined: Tue Dec 10, 2002 2:04 pm
Location: France
Name: Gilles W.
Contact: