Warning: The author of this contribution does not provide support for it anymore.

Quick Title Edition

General Error: Table ... doesn't exist [1146] - Quick Title Edition

General Error: Table ... doesn't exist [1146]

by Nagl » Thu Jun 23, 2011 7:27 pm

I installed this mod yesterday using Automod and I did run the db file. When I go to the ACP and try to look at the mod under Posting->Topics Attributes it gives me this error.
General Error
SQL ERROR [ mysqli ]

Table 'phpbbtest2.TOPICS_ATTR_TABLE' doesn't exist [1146]

SQL

SELECT * FROM TOPICS_ATTR_TABLE ORDER BY left_id ASC

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/functions_attributes.php
LINE: 32
CALL: dbal_mysqli->sql_query()

FILE: includes/functions_attributes.php
LINE: 439
CALL: qte->qte()

FILE: includes/acp/acp_attributes.php
LINE: 26
CALL: include('includes/functions_attributes.php')

FILE: includes/functions_module.php
LINE: 507
CALL: acp_attributes->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

Any help would be deeply appreciated.
Nagl
Registered User
Posts: 9
Joined: Thu Jun 23, 2011 7:16 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Nagl » Mon Jun 27, 2011 4:02 am

I would also like to point on this same issue is in this thead, http://www.phpbb.com/customise/db/mod/q ... iew_unread , but the link in the solution is broken.
Nagl
Registered User
Posts: 9
Joined: Thu Jun 23, 2011 7:16 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Skouat » Mon Jun 27, 2011 6:23 pm

Check your modification in "includes/constants.php"

You must add :

Code: Select all

//-- mod : quick title edition -------------------------------------------------
//-- add
define('TOPICS_ATTR_TABLE'$table_prefix 'topics_attr');
//-- fin mod : quick title edition ---------------------------------------------    
Skouat
Code Contributor
Posts: 888
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Nagl » Tue Jun 28, 2011 2:59 am

I will try that later tonight, if it works you will become my hero!

Edit:You are my hero! You deserve an E-cookie and just to make sure for anyone else reading this here is the instructions in supa ez forum from install.xml.

Find
Tip: This may be a partial find and not the whole line.

Code:Select All
// Additional tables
Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.

Code:Select all
//-- mod : quick title edition -------------------------------------------------
//-- add
define('TOPICS_ATTR_TABLE', $table_prefix . 'topics_attr');
//-- fin mod : quick title edition ---------------------------------------------


Thank you very much!
Nagl
Registered User
Posts: 9
Joined: Thu Jun 23, 2011 7:16 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Barlos » Tue Jul 12, 2011 5:42 am

I am also getting the db no exist.
SQL ERROR [ mysqli ]

Table 'phpbb3test.phpbb_topics_attr' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
Please notify the board administrator or webmaster:


However, I run it on the newly released 3.0.9.

After I install via automod, then tried to run the db_update.php, then the above error msg came out.

It seems the phpbb_topics_attr table could not be created. It seem that db_update.php could not be execute properly.

Best Regards
Barlos
Registered User
Posts: 16
Joined: Thu Jun 18, 2009 4:49 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Barlos » Tue Jul 12, 2011 6:29 am

Here is my test.

If I install QTE to a newly install phpbb, it will install just fine. Both 3.0.9 and 3.0.8.

However, I installed QTE to a upgraded phpbb fourm, then I won't able to installed properly. In my case, 3.0.8 upgraded to 3.0.9.

The upgraded 3.0.9 won't run db_update.php to creat phpbb_topics_attr table.
Barlos
Registered User
Posts: 16
Joined: Thu Jun 18, 2009 4:49 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Skouat » Sat Jul 16, 2011 9:53 am

No problem for me on the both methods.
=> Fresh install 3.0.8 and fresh install 3.0.9
=> 3.0.8 Ugraded to 3.0.9

When you launch "db_update.php" at the end you have a summary.
If the summary doesn't report errors, then everything is OK

You can try to uninstall it by launching "db_update.php"
Skouat
Code Contributor
Posts: 888
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: General Error: Table ... doesn't exist [1146]

by iRyusa » Fri Jul 22, 2011 4:22 pm

Hi,
i've the same problem, but i can't go on db_update.php it ask me to loggin and loggin is broken with this message :(

Edit: How to fix for my case =>
Exec Db_update.php before installing the mod
Last edited by iRyusa on Fri Jul 22, 2011 6:45 pm
iRyusa
Registered User
Posts: 6
Joined: Fri Jul 22, 2011 4:19 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by iRyusa » Fri Jul 22, 2011 4:29 pm

Edit:Dhaa i havent seen that modered post :( such a noob
Last edited by iRyusa on Fri Jul 22, 2011 6:44 pm
iRyusa
Registered User
Posts: 6
Joined: Fri Jul 22, 2011 4:19 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Skouat » Fri Jul 22, 2011 9:38 pm

Hi,
iRyusa wrote:i've the same problem

The first one isn't the same problem than the second. And I think that your problem is a third problem.
Open your own topic, it's better for everybody and quote your "General Error".


iRyusa wrote:How to fix for my case =>
Exec Db_update.php before installing the mod

After
Because if you don't do the changes requested before Exec Db_update.php , you can have a "General Error" :roll:
Skouat
Code Contributor
Posts: 888
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: General Error: Table ... doesn't exist [1146]

by iRyusa » Sun Jul 31, 2011 11:40 pm

Skouat wrote:Hi,
iRyusa wrote:i've the same problem

The first one isn't the same problem than the second. And I think that your problem is a third problem.
Open your own topic, it's better for everybody and quote your "General Error".


iRyusa wrote:How to fix for my case =>
Exec Db_update.php before installing the mod

After
Because if you don't do the changes requested before Exec Db_update.php , you can have a "General Error" :roll:

Not really, i had to do before installing. When i install it with Auto Mod, the db_update.php ask me to loggin back and loggin is broken because of the mod's change. So if i do the db update just before, table are ok and the script is installed. Btw probably a cookie problems
iRyusa
Registered User
Posts: 6
Joined: Fri Jul 22, 2011 4:19 pm
Contact:

Re: General Error: Table ... doesn't exist [1146]

by Skouat » Mon Aug 01, 2011 6:24 pm

Skouat wrote:Hi,
iRyusa wrote:i've the same problem


The first one isn't the same problem than the second. And I think that your problem is a third problem.
Open your own topic, it's better for everybody and quote your "General Error"

;)
Skouat
Code Contributor
Posts: 888
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: General Error: Table ... doesn't exist [1146]

by oltretutto » Sat Oct 15, 2011 4:21 pm

Hi,
i've the same problem as Barlos, i can't go on db_update.php it ask me to login and login is broken with this message.

Error:

Code: Select all

forum.phpbb_topics_attr' doesn't exist [1146]
An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


My forum is this:
http://www.oltrecomics.com/forum/

Help me pleaseee :oops:

Sorry for my bad english
oltretutto
Registered User
Posts: 6
Joined: Wed Feb 13, 2008 7:14 am
Contact:

Re: General Error: Table ... doesn't exist [1146]

by oltretutto » Sun Oct 16, 2011 1:43 am

Solved!
In short, I opened the file ucp.php in my forum root and I deleted the following line:

Code: Select all

include $phpbb_root_path . 'includes/functions_attributes.' . $phpEx;

I uploaded the file via ftp
I am logged in as administrator
I reopened ucp.php file> I added the line that I had deleted> I uploaded the file to the root via ftp
and I launched the file "db_update.php".
Everything now works perfectly

Thanks everyone!
oltretutto
Registered User
Posts: 6
Joined: Wed Feb 13, 2008 7:14 am
Contact: