Warning: The author of this contribution does not provide support for it anymore.

Red Blinking PM

no blink except on ACP login page - Red Blinking PM

no blink except on ACP login page

by techman41973 » Wed Jun 05, 2013 5:33 am

Quite odd. This MOD was working fine.
Recently, when users log in and have a new PM message, the text shows appropriate (large font and red),
but doesn't blink. It blinks on only ONE page, which is the ACP login screen
/forum/adm/index.php
Perhaps someone has an idea what could cause this behavior.
techman41973
Registered User
Posts: 410
Joined: Thu Mar 28, 2013 10:27 pm
Contact:

Re: no blink except on ACP login page

by all4phone » Sun Jun 09, 2013 2:16 pm

it looks like a jquery conflict...
Is located jquery-blink.js file in root/styles/your_style/template directory ?

Also See these topics:
viewtopic.php?p=13013841#p13013841
http://phpbbmods.cba.pl/viewtopic.php?p=15#p15
http://phpbbmods.cba.pl/viewtopic.php?p=12#p12
and check overall_header.html file of your style.
User avatar
all4phone
Registered User
Posts: 593
Joined: Fri Mar 18, 2011 11:56 am
Location: Poland
Name: Piotr
Contact:

Re: no blink except on ACP login page

by techman41973 » Thu Jun 13, 2013 2:14 am

Yes. jquery-blink.js file is in
root/styles/your_style/template directory

This is the code in my overall_header file

Code: Select all


<!-- IF (S_RBPM_ENABLE or S_RBPM_INSC_ENABLE) and S_USER_NEW_PRIVMSG -->
<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/jquery-1.7.2.min.js"></script>
<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/jquery-blink.js"></script>
<script type="text/javascript" charset="utf-8">
// <![CDATA[
$(document).ready(function(){
        $('.blink').blink();
});
// ]]>
</script><!-- ENDIF -->



I tried removing line

Code: Select all

<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/jquery-1.7.2.min.js"></script>


This did not solve the problem.
Perhaps you can advise on some other things to try.
Thank you
techman41973
Registered User
Posts: 410
Joined: Thu Mar 28, 2013 10:27 pm
Contact:

Re: no blink except on ACP login page

by all4phone » Thu Jun 13, 2013 8:23 am

I hope that your board version is 3.0.11 ?

The jQuery should never be included on a page more than once.
So, if you have installed on your board other modifications that use the jQuery library also, give me a little bit more of your overall_header.html file, i'll check it out.

(In particular include a whole section <head>...</head>, please.)
User avatar
all4phone
Registered User
Posts: 593
Joined: Fri Mar 18, 2011 11:56 am
Location: Poland
Name: Piotr
Contact:

Re: no blink except on ACP login page

by techman41973 » Sun Jun 16, 2013 1:23 am

Yes. It worked! I will keep testing to make sure my other MODs are not effected.
Thanks for all of your help, great MOD and great support.
techman41973
Registered User
Posts: 410
Joined: Thu Mar 28, 2013 10:27 pm
Contact:

Re: no blink except on ACP login page

by all4phone » Sun Jun 16, 2013 1:42 am

Thanks for sending the code of your overal_header.html file and thanks for testing this mod.

I'm glad I could help you ;)
User avatar
all4phone
Registered User
Posts: 593
Joined: Fri Mar 18, 2011 11:56 am
Location: Poland
Name: Piotr
Contact: