Warning: The author of this contribution does not provide support for it anymore.

Red Blinking PM

can't get color of unread messages when there is 0 new - Red Blinking PM

can't get color of unread messages when there is 0 new

by techman41973 » Wed Jul 17, 2013 12:34 am

I've set up this MOD so that when a user has new private messages, it flashes in a bigger font and in red.
But when a user has 0 new message with 1 or more unread, I want the the words "1 unread message"
to appear in red and in bold (no flash). Is this possible. I can't seem to make this work in settings.
techman41973
Registered User
Posts: 410
Joined: Thu Mar 28, 2013 10:27 pm
Contact:

Re: can't get color of unread messages when there is 0 new

by all4phone » Thu Jul 18, 2013 9:26 pm

This mod has no such option yet ;)

If you are really depend for this:
Open styles/your_style/template/overall_header.html
Find:

Code: Select all

<!-- IF S_RBPM_ENABLE_UNREAD and PRIVATE_MESSAGE_INFO_UNREAD -->
               &amp; {PRIVATE_MESSAGE_INFO_UNREAD}
            <!-- ELSE -->
            <!-- ENDIF -->

Replace with:

Code: Select all

<!-- IF S_RBPM_ENABLE_UNREAD and PRIVATE_MESSAGE_INFO_UNREAD -->
               &amp; <span style="color:{S_RBPM_UNREAD_COLOR};font-weight:{S_RBPM_BOLD}">{PRIVATE_MESSAGE_INFO_UNREAD}</span>
            <!-- ELSE -->
            <!-- ENDIF -->


Unread messages will shown in red and bold provided that you set the color and font weight in the ACP (tab Color - "Colour of unread: choose the color" / tab Font - "Font weight: mark bold").

Is that enough?
User avatar
all4phone
Registered User
Posts: 593
Joined: Fri Mar 18, 2011 11:56 am
Location: Poland
Name: Piotr
Contact:

Re: can't get color of unread messages when there is 0 new

by techman41973 » Thu Jul 18, 2013 9:41 pm

I actually figured this change out on my own. But thanks for posting this for me and others,.
Great mod and great support!
techman41973
Registered User
Posts: 410
Joined: Thu Mar 28, 2013 10:27 pm
Contact:

Re: can't get color of unread messages when there is 0 new

by all4phone » Thu Jul 18, 2013 10:29 pm

No probs, thanks for testing ;)
User avatar
all4phone
Registered User
Posts: 593
Joined: Fri Mar 18, 2011 11:56 am
Location: Poland
Name: Piotr
Contact: