Warning: The author of this contribution does not provide support for it anymore.

Thanks for posts

After updating forum to 3.2.0 mod doesn't work - Thanks for posts

After updating forum to 3.2.0 mod doesn't work

by niebrat » Sat Jan 14, 2017 11:51 pm

Hi. I love this extension but unfortunelly after forum update to 3.2.0 this doesn't work and break the forum with error:

Code: Select all

Catchable fatal error: Argument 1 passed to phpbb\notification\type\base::__construct() must implement interface phpbb\db\driver\driver_interface, instance of phpbb\user_loader given, called in /homepages/41/d339986667/htdocs/aleyoya/cache/production/container_4335734bbdd20f586549a504dff5f80c.php on line 2118 and defined in /homepages/41/d339986667/htdocs/aleyoya/phpbb/notification/type/base.php on line 87
niebrat
Registered User
Posts: 2
Joined: Sat Jan 14, 2017 11:48 pm
Contact:

Re: After updating forum to 3.2.0 mod doesn't work

by DarkD67 » Fri Jan 27, 2017 10:26 am

It's using umil as part of the install looking at the files. That's not there in 3.2 so we need to wait until they update to the new extension format.
Would love to see this working in 3.2
DarkD67
Registered User
Posts: 5
Joined: Tue Jan 17, 2017 5:08 am
Contact:

Re: After updating forum to 3.2.0 mod doesn't work

by richey » Mon Mar 06, 2017 8:11 am

Oh yeah, but there's a message up there that this extension is basically abandoned.

Is there a routine on PHPBB to propose an extension for picking up development again?
Unfortunately, I'm not familiar enough with phpbb architecture to do it myself.

The "Thanks" mod was really useful... :-(
.
richey
Registered User
Posts: 612
Joined: Mon Feb 18, 2002 4:26 pm
Location: now@Cyberspace
Contact:

Re: After updating forum to 3.2.0 mod doesn't work

by JimA » Mon Mar 06, 2017 7:28 pm

richey wrote:Oh yeah, but there's a message up there that this extension is basically abandoned.

Is there a routine on PHPBB to propose an extension for picking up development again?
Unfortunately, I'm not familiar enough with phpbb architecture to do it myself.
That message is there because this is a modification, which only work on phpBB version 3.0.x, which is currently not supported anymore and therefore that goes for this MOD as well.

However, there is currently an extension version in development that is supposed to work on phpBB 3.2 as well, you can find the development topic over here. :)
Image Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.
User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7579
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: After updating forum to 3.2.0 mod doesn't work

by richey » Mon Mar 06, 2017 9:46 pm

Thanks for your update on that -- that's great news! :)
.
richey
Registered User
Posts: 612
Joined: Mon Feb 18, 2002 4:26 pm
Location: now@Cyberspace
Contact: