Warning: The author of this contribution does not provide support for it anymore.

Topic Text in Mouse Over

Cannot find "topichover_db_update.php" - Topic Text in Mouse Over

Cannot find "topichover_db_update.php"

by Anonymous » Mon Jun 07, 2010 5:48 pm

I'm guessing this is a really stupid mistake, but I can't seem to see what my problem is...and thanks for your patience with us amateurs :oops:

I used AutoMOD to install this mod and it seems to install fine with no errors. But when I browse to:

www.myforum.com/forum/topichover_db_update.php

The file is not there and so I cannot make the database changes. I'm assuming that AutoMOD is supposed to be copying the topichover_db_update.php file to my root directory and since it did not I don't want to go mucking about until I can confirm what the problem is.

Can you suggest a best course of action for me? Many thanks.
Anonymous
I am too lazy to register
Posts: 3189
Joined: Thu Mar 15, 2007 6:50 am
Contact:

Re: Cannot find "topichover_db_update.php"

by RMcGirr83 » Mon Jun 07, 2010 6:07 pm

Via FTP browse to your forum directory and see if the file is there and yes automod should have copied it over (assuming the permissions for the directory structure are set correctly).
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21059
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Cannot find "topichover_db_update.php"

by Anonymous » Mon Jun 07, 2010 6:17 pm

Thanks for the fast reply :)

When I look via FTP the file is definitely not in my root directory.

So I suppose that there is a permissions problem?

Is it OK to just copy the file to my root directory manually?
Anonymous
I am too lazy to register
Posts: 3189
Joined: Thu Mar 15, 2007 6:50 am
Contact:

Re: Cannot find "topichover_db_update.php"

by RMcGirr83 » Mon Jun 07, 2010 6:30 pm

Yes it is okay to copy the file manually but then there is no guarantee that the other files on your forum were edited correctly or at all so you would probably have to check each one.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21059
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Cannot find "topichover_db_update.php"

by Anonymous » Mon Jun 07, 2010 6:46 pm

When I ran the installation using AutoMOD it reported that it was installed successfully...but I just looked at a few files and they were NOT edited.

So it looks like my problem is unrelated to your MOD :oops:

Do you think that the problem has to do with permissions? Would you be able to point me in the right direction to get this sorted?

Thanks again
Anonymous
I am too lazy to register
Posts: 3189
Joined: Thu Mar 15, 2007 6:50 am
Contact:

Re: Cannot find "topichover_db_update.php"

by RMcGirr83 » Mon Jun 07, 2010 6:55 pm

Yes I believe it has to do with the permissions as they are set on your directory structure. Maybe this will be some help
[kb=phpbb3-chmod-permissions]phpBB3 Chmod Permissions[/kb]
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21059
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Cannot find "topichover_db_update.php"

by Anonymous » Mon Jun 07, 2010 7:20 pm

Yes that link solved the problem for me - many thanks to you!

The MOD is working 100% for me now in subsilver2 and prosilver :P What a great mod. It looks fantastic.

However, I am using Hermes Gray style so I'm not done yet. When I try to apply the subsilver2 changes to the Hermes Gray template, I get this error:

Code: Select all

styles/Hermes Gray/template/viewforum_body.html
Find
<a title="{L_POSTED}: {topicrow.FIRST_POST_TIME}" href="{topicrow.U_VIEW_TOPIC}"class="topictitle">{topicrow.TOPIC_TITLE}
--------------------------------------------------------------------------------

In-Line Find
title="{L_POSTED}: {topicrow.FIRST_POST_TIME}"
--------------------------------------------------------------------------------

The In-Line Find specified by the MOD could not be found.The Find specified by the MOD could not be found


Sorry, but I'm stuck again...what to do?
Anonymous
I am too lazy to register
Posts: 3189
Joined: Thu Mar 15, 2007 6:50 am
Contact:

Re: Cannot find "topichover_db_update.php"

by RMcGirr83 » Mon Jun 07, 2010 7:34 pm

Are you getting any other errors concerning the install onto Hermes Grey?
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21059
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Cannot find "topichover_db_update.php"

by Anonymous » Mon Jun 07, 2010 7:39 pm

Nope - all the other edits list "success"

It is just the one "not found" error that I posted above.
Anonymous
I am too lazy to register
Posts: 3189
Joined: Thu Mar 15, 2007 6:50 am
Contact:

Re: Cannot find "topichover_db_update.php"

by RMcGirr83 » Mon Jun 07, 2010 7:50 pm

Well there are two ways to handle this, one is to edit the subsilver2.xml file from the mod and the other I think will suit you better.

Click the "Force Install" on Automod (you will get a warning...just keep going), then download the Hermes Grey viewforum_body.html file. Open the file in a strict text editor (like notepad++) DO NOT USE DREAMWEAVER!!

The lines you have to edit will be found on lines 43 and 203 of that file and look very smiliar to this

Code: Select all

<a title="{L_POSTED}: {topicrow.FIRST_POST_TIME}" href="{topicrow.U_VIEW_TOPIC}" class="topictitle<!-- IF topicrow.S_UNREAD_TOPIC --> link-new<!-- ENDIF -->">{topicrow.TOPIC_TITLE}</a>


the reason automod couldn't install it is due to the

Code: Select all

<!-- IF topicrow.S_UNREAD_TOPIC --> link-new<!-- ENDIF -->


found in that file. You will want both lines I stated above to look like this (or close to this)

Code: Select all

<a <!-- IF topicrow.FIRST_TEXT_HOVER -->title="{topicrow.FIRST_TEXT_HOVER}"<!-- ELSE -->title="{L_POSTED}: {topicrow.FIRST_POST_TIME}" <!-- ENDIF --> href="{topicrow.U_VIEW_TOPIC}" class="topictitle<!-- IF topicrow.S_UNREAD_TOPIC --> link-new<!-- ENDIF -->">{topicrow.TOPIC_TITLE}</a>


once the edits are done, go to the ACP and refresh the hermes grey style and you should then be all set.


Please remember there are two of the same lines within that file and you have to do both of them. Make a backup of that file just in case you run into any problems.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21059
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Cannot find "topichover_db_update.php"

by Anonymous » Tue Jun 08, 2010 1:45 am

OK, sounds like this isn't that hard to fix :)

One more problem though. When I run the "force install" it appears that the install is actually being done on the subsilver2 files and not the Hermes Gray files. Under the "file edits" section after I force the install all the references are to subsilver2 files. Shouldn't these references be to the Hermes Gray files? I am now using the "compressed file download" write method option under AutoMOD config if that matters. The zip file that is created contains new versions of subsilver2 files and not Hermes Gray files. I hope this makes sense...

So far I haven't made any file changes. Thanks again for your help. It seems kind of unfair that not only do the developers of these great MODs go through the time and effort to *create* the mods, but you also get stuck with almost all of the support! My hat goes off to you.
Anonymous
I am too lazy to register
Posts: 3189
Joined: Thu Mar 15, 2007 6:50 am
Contact:

Re: Cannot find "topichover_db_update.php"

by RMcGirr83 » Tue Jun 08, 2010 7:53 am

Hmmm, well I guess it's number one way then.

download the subsilver2.xml file from your /store/mods/topic_text_hover/contrib directory then open it in notepad++ and

FIND

Code: Select all

<find><![CDATA[<a title="{L_POSTED}: {topicrow.FIRST_POST_TIME}" href="{topicrow.U_VIEW_TOPIC}"class="topictitle">{topicrow.TOPIC_TITLE}]]></find>


replace it with

Code: Select all

<find><![CDATA[<a title="{L_POSTED}: {topicrow.FIRST_POST_TIME}" href="{topicrow.U_VIEW_TOPIC}"]]></find>


then find

Code: Select all

<find><![CDATA[<a title="{L_POSTED}: {topicrow.FIRST_POST_TIME}" href="{topicrow.U_VIEW_TOPIC}" class="topictitle">{topicrow.TOPIC_TITLE}]]></find>


replace it with

Code: Select all

<find><![CDATA[<a title="{L_POSTED}: {topicrow.FIRST_POST_TIME}" href="{topicrow.U_VIEW_TOPIC}"]]></find>


reupload the file and try to install it again onto hermes grey.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21059
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Cannot find "topichover_db_update.php"

by Anonymous » Wed Jun 09, 2010 1:42 am

awesome!!!! works perfectly!

Thanks so much, your MOD has made a big difference!
Anonymous
I am too lazy to register
Posts: 3189
Joined: Thu Mar 15, 2007 6:50 am
Contact:

Re: Cannot find "topichover_db_update.php"

by RMcGirr83 » Wed Jun 09, 2010 10:20 am

:)

Glad to hear it...enjoy the mod!!
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21059
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact: