Warning: The author of this contribution does not provide support for it anymore.

User Blog Mod

Subscribing to Blog - User Blog Mod

Subscribing to Blog

by ArgyrosfeniX » Thu Jul 30, 2015 7:16 pm

I just finished installing the Blog Mod onto a friend's website and one of the registered users was asking about notifications. I noticed that there are "subscriptions" mentioned in the ACP.

SP32-20150730-131436.png
SP32-20150730-131436.png (4.38 KiB) Viewed 120 times


I'm not finding the place where users are able to click to subscribe. Not certain if there is something wrong with the code or the install, but everything else seems to be working well.

phpBB version 3.0.12 using subSilver style.

Thanks in advance for any assistance!

Brent
.
. Here I am trying to live, or rather, I am trying to teach the death within me how to live. ~ Jean Cocteau
.
User avatar
ArgyrosfeniX
Registered User
Posts: 60
Joined: Tue Jul 26, 2005 2:46 pm
Location: Greater St. Paul, MN Suburb
Contact:

Re: Subscribing to Blog

by phpchr » Thu Aug 06, 2015 2:21 pm

Hi!
As I see, you have enabled subscriptions in admin panel<.mods<blog settings. Perhaps you should go to admin panel<view user-based permissions, select the user in question and check for a "yes" in "can comment on blog entries".

In user control panel ensure you have set blog permissions correctly. However, if you have enabled "user permissions" in admin panel<.mods<blog settings, you should check for override values in the particular blog (edit blog entry).

Hopefully you should see "subscribe to this blog" link now regardless of the style you use (I have tested prosilver, coda and blogger clone styles).

The notification is configured in user control panel<blog settings and maybe in each blog individually.

Good luck
phpchr
Registered User
Posts: 16
Joined: Mon Jul 02, 2012 8:26 pm
Contact:

Re: Subscribing to Blog

by ArgyrosfeniX » Thu Aug 06, 2015 4:27 pm

phpchr wrote:Hi!
As I see, you have enabled subscriptions in admin panel<.mods<blog settings. Perhaps you should go to admin panel<view user-based permissions, select the user in question and check for a "yes" in "can comment on blog entries".

In user control panel ensure you have set blog permissions correctly. However, if you have enabled "user permissions" in admin panel<.mods<blog settings, you should check for override values in the particular blog (edit blog entry).

Hopefully you should see "subscribe to this blog" link now regardless of the style you use (I have tested prosilver, coda and blogger clone styles).

The notification is configured in user control panel<blog settings and maybe in each blog individually.

Good luck

I've tried all the suggestions above and can't get the subscription link to appear...

Just in case: Where should I be looking for this link? Just a certain page, or all pages of a person's blog?

I'm going to see if I can track down where it is in the code and backtrack in the hopes of finding where there's an error. I'll also be double checking the install. *sigh*

Any other ideas would be greatly appreciated!

:mrgreen:
.
. Here I am trying to live, or rather, I am trying to teach the death within me how to live. ~ Jean Cocteau
.
User avatar
ArgyrosfeniX
Registered User
Posts: 60
Joined: Tue Jul 26, 2005 2:46 pm
Location: Greater St. Paul, MN Suburb
Contact: