phpBB QuickInstall

Quick install breaks with PHP 5.5.7 - phpBB QuickInstall

Quick install breaks with PHP 5.5.7

by Danielx64 » Mon Jan 13, 2014 12:10 pm

I am on my phone but the short version is that when I create a new test board with users and posts it will complains about some of the functions being removed. More details will be provided when I get up.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image
Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: Quick install breaks with PHP 5.5.7

by Danielx64 » Mon Jan 13, 2014 11:33 pm

Ok now that I'm on my desktop, I can post the full error that I'm getting.

[14-Jan-2014 08:28:44 Australia/Victoria] PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in H:\wamp\www\phpbb\boards\test2\includes\functions_content.php on line 678

Odd thing is that this will only happen when running quick install and telling it to create users and posts.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image
Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: Quick install breaks with PHP 5.5.7

by tumba25 » Mon Jan 13, 2014 11:54 pm

That is probably because that function, make_clickable(), is only called then. That is not a QI error, make_clickable() is a phpBB function.
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net
User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact:

Re: Quick install breaks with PHP 5.5.7

by Danielx64 » Mon Jan 13, 2014 11:56 pm

So that should go into the phpBB bug tracker?
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image
Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: Quick install breaks with PHP 5.5.7

by tumba25 » Tue Jan 14, 2014 12:11 am

Yes
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net
User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact:

Re: Quick install breaks with PHP 5.5.7

by Danielx64 » Tue Jan 14, 2014 12:30 am

Well I think I'm getting the run around here, been told that it very unlikely a phpBB core problem......

http://tracker.phpbb.com/browse/PHPBB3- ... ment-40803
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image
Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: Quick install breaks with PHP 5.5.7

by watisnf.nl » Mon Nov 03, 2014 6:08 pm

Is there any news on this? I read in that other treat that this is reported to the QI bug tracker. But I got QI recently and I'm getting the same error, but it's still installing the board that I made so it 'works' it just gives a error.
Dutch Translator | Looking for, Dutch extensions translations
User avatar
watisnf.nl
Registered User
Posts: 607
Joined: Sat Mar 13, 2010 12:53 pm
Location: The Netherlands
Name: David
Contact:

Re: Quick install breaks with PHP 5.5.7

by tumba25 » Wed Nov 19, 2014 5:24 pm

That is not a error, it is a warning. This is fixed in the unstable version at https://github.com/phpbb/quickinstall.
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net
User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact: