phpBB QuickInstall

1.2.1-dev - UTF-8 characters are not supported in $error_msg - phpBB QuickInstall

1.2.1-dev - UTF-8 characters are not supported in $error_msg

by Skouat » Thu Dec 04, 2014 7:33 pm

Hi Tumba25,

When we create a board and if the board dir ou board BD already exist, a "Minor mishap" appears.
The error message doesn't support UTF-8 chars.
minor_mishap_01.png
minor_mishap_01.png (5.83 KiB) Viewed 178 times


in qi_main.php, if I replace

Code: Select all

$error_msg = $settings->get_config('error_msg', '');

With

Code: Select all

$error_msg = $settings->get_config('error_msg', '', true);

It seems to works fine, but I'm not sure that is the correct Fix for this error.

I wished to create an issue on JIRA, but it is not possible to select the EXTTOOLS project from the ticket creation form.

Regards.
Skouat
Code Contributor
Posts: 656
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: 1.2.1-dev - UTF-8 characters are not supported in $error

by tumba25 » Thu Dec 04, 2014 9:40 pm

https://github.com/phpbb/quickinstall/issues is the place for bug reports.

That is the correct fix, thanks. Will in the repo soon.
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net
User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact:

Re: 1.2.1-dev - UTF-8 characters are not supported in $error

by Skouat » Sat Dec 06, 2014 11:13 am

Hi tumba25,

Do I create the ticket on Github or it's not necessary?
Skouat
Code Contributor
Posts: 656
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: 1.2.1-dev - UTF-8 characters are not supported in $error

by tumba25 » Sat Dec 06, 2014 11:32 am

No that's not necessary.
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net
User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact:

Re: 1.2.1-dev - UTF-8 characters are not supported in $error

by Skouat » Tue Mar 03, 2015 8:52 pm

Hi tumba25,

We have missed a variable which is also impacted by this issue.

Code: Select all

         'ERROR_TITLE'   => $settings->get_config('error_title', ''),

should be

Code: Select all

         'ERROR_TITLE'   => $settings->get_config('error_title', '',true),


Regards
Skouat
Code Contributor
Posts: 656
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact: