Bl@ck

trying to install mchat - Bl@ck

trying to install mchat

by SQ2010 » Wed Nov 02, 2011 6:15 pm

Hi,

I installed mchat and it work great on prosilver style but I can't make the same modifications on this style because I am missing...

styles/bl@ck/template/editor.js

and

styles/bl@ck/template/index_body.html

I see the chat box in the style but when I try to use it, it does not work. My text does not show in the window.

What can I do? I really prefer this style over the generic one. Thanks!
SQ2010
Registered User
Posts: 4
Joined: Sun Oct 30, 2011 9:21 pm
Contact:

Re: trying to install mchat

by pit-PL » Wed Nov 02, 2011 7:32 pm

Open Bl@ck/template/overall_header.html find </head>
add before

Code: Select all

<!-- IF S_MCHAT_ENABLE and (S_MCHAT_ON_INDEX or U_MCHAT) -->
<script type="text/javascript" src="{ROOT_PATH}mchat/jquery-1.5.0.min.js"></script>
<script type="text/javascript" src="{ROOT_PATH}mchat/jquery_cookie_mini.js"></script>
<!-- ENDIF -->
User avatar
pit-PL
Registered User
Posts: 3080
Joined: Sat Nov 21, 2009 12:24 pm
Contact:

Re: trying to install mchat

by sevenalive » Wed Nov 02, 2011 8:35 pm

Bl@ck uses the prosilver files, so You only need to make the modifications for files that Bl@ck has, like overall_header.

I would advise you use autoMOD as it automates installing mods for you. It can also install mods into custom styles.
User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert
Contact:

Re: trying to install mchat

by SQ2010 » Thu Nov 03, 2011 1:11 pm

I will install autoMOD, thanks :) So I added the code in the overall_header.html file and I see the chat, but it still does not work. When I type something, it does not show.

Also the text is black on dark grey. Where can I change that?
SQ2010
Registered User
Posts: 4
Joined: Sun Oct 30, 2011 9:21 pm
Contact:

Re: trying to install mchat

by pit-PL » Thu Nov 03, 2011 4:15 pm

Copy prosilver/theme/mchat.css to Bl@ck/theme/
Open Bl@ck/theme/stylesheet.css find @import url("borders.css");
add after @import url("mchat.css");
Go to the ACP styles tab refresh template and theme.
User avatar
pit-PL
Registered User
Posts: 3080
Joined: Sat Nov 21, 2009 12:24 pm
Contact:

Re: trying to install mchat

by SQ2010 » Thu Nov 03, 2011 6:40 pm

ok it worked Thanks! Now 2 questions. Can I desactivate prosilver and Bl@ck will still work? How can I change the text color or background color of the chat for the Bl@ck style?
SQ2010
Registered User
Posts: 4
Joined: Sun Oct 30, 2011 9:21 pm
Contact:

Re: trying to install mchat

by pit-PL » Thu Nov 03, 2011 7:30 pm

Do not deactivate prosilver. It will come in handy if you ever have problems with the Bl@ck or other styles.

In mchat.css of course.
User avatar
pit-PL
Registered User
Posts: 3080
Joined: Sat Nov 21, 2009 12:24 pm
Contact:

Re: trying to install mchat

by sevenalive » Thu Nov 03, 2011 9:18 pm

Bl@ck requires prosilver.
User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert
Contact:

Re: trying to install mchat

by malleymom » Sun Jul 01, 2012 2:07 am

Sorry to revive a dead thread, but I've just installed mChat, on a forum using your style. When I have prosilver active, the system works flawlessly. When I switch the style over to Bl@ck, I can't "press" any of the buttons (send/reset). I've changed the css and header files.. . What am I missing?

You can check out the error yourself HERE. User credentials are TestChump, password: "bigkev"
malleymom
Registered User
Posts: 3
Joined: Sun Jul 01, 2012 1:56 am
Contact:

Re: trying to install mchat

by sevenalive » Sun Jul 01, 2012 11:16 am

You should use automod instead. Your editor.js file is missing.

You can use the same javascript files in the prosilver folder by using {T_SUPER_TEMPLATE_PATH}

You should use

Code: Select all

<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/editor.js"></script>


It will look for the javascript in the prosilver folder. So you don't need duplicate files.
User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert
Contact:

Re: trying to install mchat

by malleymom » Sun Jul 01, 2012 6:47 pm

Alright, I've added the editor.js to the correct directory and refreshed the style, but it still won't work. I will admit, while not being new to phpbb, I've never modded before. You mentioned using automod to install the mod (again). Would I need to go back and wipe my prosilver and Bl@ck back to default in order to do this?

Thanks in advance for your help.
malleymom
Registered User
Posts: 3
Joined: Sun Jul 01, 2012 1:56 am
Contact:

Re: trying to install mchat

by sevenalive » Sun Jul 01, 2012 7:22 pm

You would need to undo all the changes you have done. I would just upload and overwrite phpbb and bl@ck, install automod and then use that to install mods.

If you would rather try to fix it and use automod for future mods, I would double check your edits.

If a mod edits prosilver and that file exists in the bl@ck folder, then you need to make those edits to bl@ck as well. Make sure you clear your cache after any mods in the acp.
User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert
Contact:

Re: trying to install mchat

by malleymom » Mon Jul 02, 2012 4:36 pm

Got it! Thanks for the help.

Was able to add the editor.js, uninstall/install via the _install.php
malleymom
Registered User
Posts: 3
Joined: Sun Jul 01, 2012 1:56 am
Contact: