DVGFX

How to add the logo to the forum? - DVGFX

How to add the logo to the forum?

by therp » Tue Aug 17, 2010 3:03 pm

Hi. Thanks for the nice style. I was wondering how to add the logo though. I'm new, so please excuse me if it seemed too obvious :)
therp
Registered User
Posts: 55
Joined: Sun Jul 19, 2009 7:37 pm
Contact:

Re: How to add the logo to the forum?

by Vafthrutnir » Wed Aug 18, 2010 1:49 am

Open overall_header.html find

Code: Select all

<div id="site-description">
            <!--
            <h1>{SITENAME}</h1>
            <p>{SITE_DESCRIPTION}</p>
            -->
            <p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
         </div>

Before the comments (<!-- -->) add

Code: Select all

<a href="{U_INDEX}" title="{L_INDEX}" id="logo">{SITE_LOGO_IMG}</a>

If you want the site name and description also just remove the comments.

Save and refresh the template.
User avatar
Vafthrutnir
Registered User
Posts: 46
Joined: Tue Jul 03, 2007 6:49 pm

Re: How to add the logo to the forum?

by BigG-n-Tn » Thu Nov 11, 2010 4:07 am

I did per your instructions but still no logo. Any other changes? Where to load the logo image? Thanks
BigG-n-Tn
Registered User
Posts: 15
Joined: Sun Nov 07, 2010 4:13 am

Re: How to add the logo to the forum?

by DalyTek » Wed Dec 01, 2010 9:07 am

I tried the instructions as well with no luck. Into what folder do I upload the logo and what file name does it need to be? What is the code that actually displays the logo image?
DalyTek
Registered User
Posts: 10
Joined: Thu Nov 25, 2010 5:53 am
Contact:

Re: How to add the logo to the forum?

by Vafthrutnir » Wed Dec 01, 2010 4:18 pm

The code for the image itself is:

Code: Select all

{SITE_LOGO_IMG}


The logo (site_logo.png/jpg/gif/etc.) goes in the imageset folder. The imageset.cfg is setup so that no logo is set so you'll have to edit the imageset in the ACP for it to show up.
User avatar
Vafthrutnir
Registered User
Posts: 46
Joined: Tue Jul 03, 2007 6:49 pm

Re: How to add the logo to the forum?

by BigG-n-Tn » Wed Dec 01, 2010 4:33 pm

I got mine. I got it with a combination of the above instruction and another post.
BigG-n-Tn
Registered User
Posts: 15
Joined: Sun Nov 07, 2010 4:13 am

Re: How to add the logo to the forum?

by DalyTek » Wed Dec 01, 2010 9:28 pm

OK, I have added the line:

Code: Select all

<a href="{U_INDEX}" title="{L_INDEX}" id="logo">{SITE_LOGO_IMG}</a>

where indicated. My logo is names site_logo.png and is in the imageset folder.
I then pointed to this file in the ACP, but still no logo!

What did I do wrong?
DalyTek
Registered User
Posts: 10
Joined: Thu Nov 25, 2010 5:53 am
Contact:

Re: How to add the logo to the forum?

by Vafthrutnir » Mon Dec 06, 2010 5:24 am

DalyTek wrote:OK, I have added the line:

Code: Select all

<a href="{U_INDEX}" title="{L_INDEX}" id="logo">{SITE_LOGO_IMG}</a>

where indicated. My logo is names site_logo.png and is in the imageset folder.
I then pointed to this file in the ACP, but still no logo!

What did I do wrong?


Did you refresh the imageset?
User avatar
Vafthrutnir
Registered User
Posts: 46
Joined: Tue Jul 03, 2007 6:49 pm

Re: How to add the logo to the forum?

by mdallaire12 » Sun Jan 09, 2011 4:30 am

Ok, here is what I did, tell me what is wrong because I still have NO Logo. First of all, I love your Theme!!!

First, I did update overall_header.html with the code given above before (<!-- -->), giving this :

Code: Select all

<div id="site-description">
<a href="{U_INDEX}" title="{L_INDEX}" id="logo">{SITE_LOGO_IMG}</a>
            <!--
            <h1>{SITENAME}</h1>
            <p>{SITE_DESCRIPTION}</p>
            -->
            <p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
         </div>


Then I have uploaded the file and overwrite it.

Then, in the ACP, I went to the Style, Imageset and under Edit Imageset > Logos > Main Logo, I have added my image file that I had previsously uploaded in the proper folder. my file name is Site_Logo.gif and I can properly see it in my ACP as successfully uploaded (as shown below)

Image

Now, why it isn't showing? No, I have not refresh imageset After I did this. Thanks again!
"Pressure makes diamonds"
- Gen G.S. Patton

Site : Northern Defenders - Gaming community
mdallaire12
Registered User
Posts: 20
Joined: Tue Dec 21, 2010 7:04 pm
Contact:

Re: How to add the logo to the forum?

by Vafthrutnir » Sun Jan 09, 2011 5:15 am

Have you refreshed the template?

Also you don't need to keep the code in the comments, you can just remove that if you don't need it.
User avatar
Vafthrutnir
Registered User
Posts: 46
Joined: Tue Jul 03, 2007 6:49 pm

Re: How to add the logo to the forum?

by mdallaire12 » Sun Jan 09, 2011 5:19 am

Should I refresh the template?! And (just to show you how much a noob I am...) , by comment you mean that I can remove this string of code :

Code: Select all

<!--
            <h1>{SITENAME}</h1>
            <p>{SITE_DESCRIPTION}</p>
            -->
"Pressure makes diamonds"
- Gen G.S. Patton

Site : Northern Defenders - Gaming community
mdallaire12
Registered User
Posts: 20
Joined: Tue Dec 21, 2010 7:04 pm
Contact:

Re: How to add the logo to the forum?

by Vafthrutnir » Sun Jan 09, 2011 3:16 pm

You need to refresh the template after you've made changes to any of the template files.

Yes anything starting from <!-- and ending with --> is a comment.
User avatar
Vafthrutnir
Registered User
Posts: 46
Joined: Tue Jul 03, 2007 6:49 pm

Re: How to add the logo to the forum?

by mdallaire12 » Sun Jan 09, 2011 5:20 pm

Thanks thanks thanks and thanks again! It works!!!! Seriously, you've been more than helpfull!

Now, is it possible to place the logo centered on top of the board Index? Right now it looks like this when I place the banner :

Image

and I would like to either have it centered but if not possible, at least over the top of the board index so everything is not bunched up to the right of the screen!

Again, thanks in advance!
"Pressure makes diamonds"
- Gen G.S. Patton

Site : Northern Defenders - Gaming community
mdallaire12
Registered User
Posts: 20
Joined: Tue Dec 21, 2010 7:04 pm
Contact:

Re: How to add the logo to the forum?

by Vafthrutnir » Sun Jan 09, 2011 6:52 pm

Easiest fix for that would be to re-add the corner codes for the spacing instead of changing a bunch of stuff in the css files.

Replace your code with this.

Code: Select all

<div class="headerbar">
         <div class="inner"><span class="corners-top"><span></span></span>

         <div id="site-description">
            <a href="{U_INDEX}" title="{L_INDEX}" id="logo">{SITE_LOGO_IMG}</a>
            <!--<h1>{SITENAME}</h1>
            <p>{SITE_DESCRIPTION}</p>-->
            <p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
         </div>

         <span class="corners-bottom"><span></span></span></div>
      </div>


That should work.
User avatar
Vafthrutnir
Registered User
Posts: 46
Joined: Tue Jul 03, 2007 6:49 pm

Re: How to add the logo to the forum?

by mdallaire12 » Sun Jan 09, 2011 7:08 pm

Thanks. It did work but then the rest of the forum went with no bounderaries and was taking all screen... so I went back to the back-up.

I'll read a bit more, try to get some knowledge in coding and figure out a way myself, I don't want to be a burden and you were more than helpfull.
"Pressure makes diamonds"
- Gen G.S. Patton

Site : Northern Defenders - Gaming community
mdallaire12
Registered User
Posts: 20
Joined: Tue Dec 21, 2010 7:04 pm
Contact: