Flat Style

Odd Quote Marks - Flat Style

Odd Quote Marks

by wfarrell » Sat Jul 15, 2017 11:09 pm

While we're testing Flat Style, one of my users noticed that the text
Manage “Remember Me” login keys
in the UCP Profile tab looks odd. The leading quote mark overlays the R and the trailing " mark is located under the e of Me. Note that these are "curly" quote marks, and it looks almost as though the curly quotes in the fonts supplied by Flat Style are not English-style quote marks?

Whatever they are, they are certainly mis-placed with respect to other characters in the font.
--
Walt
wfarrell
Registered User
Posts: 26
Joined: Sat Jun 25, 2016 12:23 pm
Contact:

Re: Odd Quote Marks

by wfarrell » Sun Jul 16, 2017 2:01 pm

Here's a screenshot showing the problem, but you can simply paste that text string into a message when you're using Flat Style and preview it to see the same thing.
--
Walt
wfarrell
Registered User
Posts: 26
Joined: Sat Jun 25, 2016 12:23 pm
Contact:

Re: Odd Quote Marks

by wfarrell » Sun Jul 16, 2017 5:06 pm

Those odd quote marks seem to come from the Poppins font, which is used by (and supplied by) Flat Style. However, the current version of Poppins uses normal curly quotes, so possibly the version supplied with Flat Style is downlevel?
--
Walt
wfarrell
Registered User
Posts: 26
Joined: Sat Jun 25, 2016 12:23 pm
Contact:

Re: Odd Quote Marks

by eeji » Thu Jul 20, 2017 9:24 pm

Thanks for reporing, this is an odd one! My dev board is using the latest version as packaged in the FAQ tab but still has the same problem. I'll try repacking the fonts in case I missed something and release a fix if it solves the problem.
User avatar
eeji
Jr. Style Validator
Posts: 582
Joined: Fri Dec 12, 2008 9:08 pm
Location: Manchester, UK
Contact:

Re: Odd Quote Marks

by swa66 » Mon Jul 31, 2017 8:36 pm

I see this as well

esp. the "smart" quotes act weirdly:

e.g.
no spaces: test’test
space before: test ’test
space after: test’ test
space before and after: test ’ test

If you display that in the font used the quotes move into all the wrong places

IMHO something to do with kerning info in the font or something like that.
swa66
Registered User
Posts: 9
Joined: Wed Jun 03, 2009 8:59 am
Contact:

Re: Odd Quote Marks

by eeji » Mon Aug 14, 2017 5:56 pm

v1.0.2 for phpBB 3.2.1 has now been validated which fixes this bug - it was an error in the font packaging.
User avatar
eeji
Jr. Style Validator
Posts: 582
Joined: Fri Dec 12, 2008 9:08 pm
Location: Manchester, UK
Contact:

Re: Odd Quote Marks

by forumbrowser » Sat Nov 11, 2017 3:56 am

Would anyone have any idea what is causing this by chance?
It ONLY occurs when a user quotes another post - also it shows the same in the preview window.
If a user simply replies to a post, it is normal.
Thanks...
Attachments
quote error.jpg
forumbrowser
Registered User
Posts: 2
Joined: Sat Nov 11, 2017 3:52 am
Contact:

Re: Odd Quote Marks

by forumbrowser » Sat Nov 11, 2017 4:10 am

Found the solution - it was simple, and seems someone else on the board already ran into it - I just did not know how to describe the error:

https://www.phpbb.com/customise/db/styl ... pic/182021
forumbrowser
Registered User
Posts: 2
Joined: Sat Nov 11, 2017 3:52 am
Contact: