Documentation

1.1. Requirements

Graham

phpBB has a few requirements which must be met before you are able to install and use it. In this section, these requirements are explained.

  • A webserver or web hosting account running on any major Operating System with support for PHP

  • A SQL database system, one of:

    • FireBird 2.1 or above

    • MySQL 3.23 or above

    • MS SQL Server 2000 or above (directly or via ODBC)

    • Oracle

    • PostgreSQL 7.x or above

    • SQLite 2

  • PHP 4.3.3+ (>=4.3.3, >4.4.x, >5.x.x, >6.0-dev (compatible)) with support for the database you intend to use.

  • getimagesize() function enabled

  • The following PHP modules are optional, but will provide access to additional features.

    • zlib Compression support

    • Remote FTP support

    • XML support

    • Imagemagick support

    • GD support

The presence of each of these required features will be checked during the installation process, explained in Section 1.2, “Installation”.